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Abstract – QCAD is a 2D design and drawing computer-aided design (CAD) software tool. It is available for 
Linux,Apple macOS,Unix and Microsoft windows. The QCAD user interface is built on the Qt framework. 

This paper presents the results of a comparative review of several groups of open - source 
software(0SS) for modeling & analysis of constructions. Software products of two categories are 
considered. 

1) Geometrically/graphically modeling/drawing of the structures- 2D, 3D CAD. 

2) Calculation and analysis of building structures under different load conditions and geometry 
including geotechnical problems. 

3) Drawing Methods in QCAD: Cartesian Coordinate System; Useful drawings and objects. Draw 
Objects; Drawing Methods. 

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - X - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - 

INTRODUCTION 

The use of Computer-Aided Drafting introduces 
technical drawings such as building plans, interiors, 
and so on. mechanical parts and diagrams are all 
available today. The mechanical parts, point filtering, 
and diagrams, accounting purpose, economics, 
statistics are applied to different areas such as 
marketing and experimental sciences, and so on. 
Many people used trigonometry, operations research, 
etc. Computer-Aided drafting is studied to simple 
concepts you prepared and understanding. Present in 
general your fresh thoughts. No concepts or skills are 
built in this article on a basic line by line. and 
understand the many examples and detailed step-by-
step instructions in this It is an application for 
Computer-Aided Design(drafting)(CAD) in two 
dimensions, useful many fields. Algorithms as 
structure and marked the geometry in CAD concepts 
used in mathematics, such as the center of the 
rectangle, etc. used in geometry, topology, analysis, 
and approximation theory. For example, co-ordinates, 
soft blends, line segment, tangent, curved continuity 
are also combined and a non-rational locus satisfies a 
specified geometric tolerance for development of 
topologically true rational approaches. 

EXPLAIN SNAPPING TOOLS IN SHORT 

• Free(SF) 

• Grid(SG) 

• End(SE) 

• On Entity(ST) 

• Perpendicular(SU) 

• Tangential(SB) 

• Center(SC) 

• Reference(SR) 

• Middle(SM) 

• Middle Manual(SN) 

• Distance(SD) 

• Distance Manual(SH) 

• Intersection(SI) 

• Intersection Manual(SY) 

• Auto(SA) 

• Coordinate(SX) 

• Polar Coordinate(SO) 

• X/Y from Points(.X) 
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• Y/X from Points(.Y) 

• Center of Selection(SK) 

• Restrictions Off(EN) 

• Restrict Orthogonally(EO) 

• Restrict Horizontally(EH) 

• Restrict Vertically(EV) 

• Restrict Angle or Length(EL) 

• Set Relative Zero(RZ) 

• Lock Relative Zero(RL) 

SOME OF THEM EXPLAINED HERE 

• Distance 

Toolbar/Icon:  

       

Menu: Snap>Distance  

Shortcut: S,D 

Commands: snapdistance | sd 

Description 

Snaps to points with a given distance to the end point 
of lines or arcs. 

Usage 

1. In the settings toolbar, enter the distance. 

2. Move the mouse to the entity that measures 
the distance. 

3. To set a coordinate, click the left mouse 
button while the required position/view is 
shown. 

 

• Grid 

Toolbar/Icon:  

      

Menu: Snap>Grid  

Shortcut: S,G  

Commands: snapgrid | sg 

• X/Y from Points 

Toolbar/Icon:  

      

Menu: Snap>X/YfromPoints 

Shortcut: .,X 

Commands: .x 

Description 

This snap tool can be used to extract one 
coordinate (e.g. X) from the location of one existing 
entity and the other coordinate (e.g. Y) from the 
location of..another..object. 

This can for example be used to locate the center of 
a rectangle. 

This concept is also referred to as 'combining 
coordinates', 'point filtering', or 'coordinate filtering'. 

Usage 

• When specifying a position, start this tool. 

• Click a position in the drawing to lock the X 
coordinate at position. 

• Click a position in the drawing to lock the Y 
coordinate at that position. 

• Center of Selection 

Toolbar/Icon: 

      

Menu: Snap>CenterOfSelection 

Shortcut: S,K 

Commands: snapselectioncenter | sk 

Description 

Snaps to the center of the current selection. This is 
the point at the center between the leftmost and the 
rightmost edge in the X direction and the lowermost 
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and the uppermost edge in the Y direction of the 
selection 

• Free 

Toolbar/Icon: 

      

Menu: Snap>Free 

Shortcut: S,F 

Commands: snapfree | sf 

Description 

Allows free positioning using the mouse. Note that this 
is almost never the recommended way of setting 
coordinates in a CAD system except for drawing 
freehand lines. 

• Polar Coordinate 

Toolbar/Icon: 

      

Menu: Snap>PolarCoordinate 

Shortcut: S,O 

Commands: snappolar | so 

Description 

Defines a point by entering an absolute or relative 
polar coordinate. 

Usage 

• Start this tool when you have to specify a point 
and want to do so by entering a polar 
coordinate. 

• Enter the polar coordinate (radius and angle) 
in the options tool bar and choose if it is an 
absolute coordinate or a relative one (relative 
to the relative zero point). 

• Click the OK button or press Enter to confirm 
the input and set the coordinate: 

HOW TO DRAW OBJECTS USING COMMAND 
LINE 

QCad may either be controlled through the menus, 
toolbars, hotkeys or the command line. The control 

line offers a powerful method to interact with a CAD 
system. Experienced users frequently utilise their left 
hand instructions while using the right hand mouse. 
But you may wish to turn it off via the menu if you don't 
(yet) use a command-line View - Line of command 

• Line from 2 Points 

Toolbar/Icon: 

      

Menu: Draw>Line>Linefrom2Points 

Shortcut: L,I 

Commands: line | ln | li | l 

Description 

This tool lets you draw a sequence of one or more 
straight lines. 

Usage 

1. Choose the desired line type in the options 
toolbar. 

2. Define the first line segment's start point. 
You can either use the mouse or the 
terminal to enter a coordinate. 

3. Define the first line segment's start point. 
You can either use the mouse or the 
terminal to enter a coordinate: 

 

You can undo a single line segment by selecting it 
and pressing the "Undo" button.: 

 

4. If you want to restrict the angle or length of 
line segments, You can do so by selecting 
the appropriate option from the drop-down 
menu. "Restrict Angle or Length" button, 
and entering a length and / or angle. 
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• Vertical Line 

Toolbar/Icon: 

      

Menu: Draw>Line>VerticalLine 

Shortcut: L,V 

Commands: linevertical | l 

Descripion: 

Use this tool to create vertical lines. This tool is used 
like the tool for lines at a given angle, except that the 
angle is fixed to be vertical. 

• Horizontal Line 

Toolbar/Icon: 

      

Menu: Draw>Line>HorizontalLine 

Shortcut: L,H 

Commands: linehorizontal | lh 

Description 

Use this tool to create horizontal lines. This tool is 
used like the tool for lines at any given angle, except 
that the angle is fixed to be horizontal. 

LIST THE MODIFICATION TOOLS 

∎ Move / Copy(MV) 

∎ Rotate(RO) 

∎ Scale(SZ) 

∎ Mirror(MI) 

∎ Flip Horizontal(FH) 

∎ Flip Vertical(FV) 

∎ Move and Rotate(MR) 

∎ Rotate Two(R2) 

∎ Align Reference Points(AE) 

∎ Align(MA) 

∎ Offset (with Distance)(OF) 

∎ Offset (through Point)(OH) 

∎ Trim(RM) 

∎ Trim Both(TM) 

∎ Lengthen / Shorten(LE) 

∎ Stretch(SS) 

∎ Clip to Rectangle(CLR) 

∎ Chamfer / Bevel(CH) 

∎ Round(RN) 

∎ Divide(DI) 

∎ Split Entities(MS) 

∎ Break out Segment(D2) 

∎ Break out Manual(B2) 

∎ Auto Trim(AX) 

∎ Break out Gap(D3) 

∎ Reverse(RV) 

∎ Edit Text(MT) 

∎ Edit Hatch (MH) 

∎ Explode (XP) 

WHAT IS STRETCH AND MIRROR 

∎ Stretch 

Toolbar/Icon: 

 

Menu: Modify > Stretch 

Shortcut: S, S Commands: stretch | ss 

Description 

This tool extends contours and entities of 
dimension. It is also possible that all endpoints are 
moved inside a certain rectangular or polygonal 
zone. 
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Usage 

∎ Choose a rectangular (rectangular symbol) or 
polygonal area in the options toolbar (polygon 
symbol). 

∎ Set the first corner of the stretch area. 

∎ Set the second corner of the stretch area. 

∎ Set additional stretching regions for polygonal 
sections, and when completed, right-click the 
final corner. 

∎ Set a moving mouse reference point or 
provide a command line coordinate. 

∎ Set the target point. 

• Mirror 

Toolbar/Icon: 

      

Menu: Modify>Mirror 

Shortcut: M,I 

Commands: mirror | mi 

Usage 

• Select the entities you want to mirror. 

• Launch this tool. 

• Use the mouse to select a beginning point on 
the mirror axis, or type a coordinate into the 
command line. 

• Specify a second point on the mirror axis. 

• The mirror dialogue box appears. Choose 
"Delete Original" to mirror the entities without 

keeping the originals, and "Keep Original" to 
replicate them. 

• The new entities are placed on the same layer 
as the originals and have the same properties. 
To use the layer and current characteristics, 
uncheck "Utilize current layer and attributes." 

• Click "OK" to mirror the entities. 

EXPLAIN SCALE IN SHORT 

QCad invites The user may first design and then scale 
a printed page picture or enable the user to modify the 
scope of a print preview relative to the printer page. 

• Scale 

Toolbar/Icon:  

      

Menu: Modify>Scale 

Shortcut: S,Z 

Commands: scale | sz 

Description 

Scales entities by a given factor towards a given 
center. 

Usage 

∎ Select the entities you want to scale. 

∎ Launch this tool. 

∎ Set scaling centre using the mouse or input 
a command-line coordination. 

∎ The scale dialog is displayed where you 
can enter the scale factor. 

If you want to scale with two different factors in X 
and Y direction, uncheck the button for proportional 
scaling: 

 

You can then enter two different scaling factors for 
X and Y. 

If you want to scale the selection by mouse, check 
the mouse cursor button: 
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∎ Click "OK". 

∎ You must now provide a reference point and a 
destination point for the scaling operation if 
you previously selected to scale the selection 
by mouse. 

DISCUSS TRIM AND COPY 

• Trim 

Toolbar/Icon: 

      

Menu: Modify>Trim 

Shortcuts: R,M|X,T 

Commands: trim | extend | rm | xt 

Description 

Trims or extends a line, arc or ellipse to another entity. 

Usage 

∎ Choose a boundary to which one or more 
other entities are to be reduced or expanded. 

∎ Choose the entities you want the limited entity 
to trim. There are often two ways of cutting the 
entity. In the example below, you may want to 
keep the top of the line and cut the bottom 
portion off. You should click on the trimming 
object at the top In this instance. Always click 
that part of the entity which you want to retain. 

 

∎ Right click twice or press Escape twice to 
terminate the tool. 

• Move / Copy 

Toolbar/Icon: 

      

Menu: Modify>Move/Copy 

Shortcut: M,V 

Commands: move | mv 

Description 

Moves or copies entities. 

Usage 

○ Select the entities you want to move or copy. 

○ Launch this tool. 

○ Use the mouse to set the reference point, or 
type a coordinate into the command line. 

○ Decide on a target spot. Enter a relative 
coordinate to move the selected entities by a 
certain amount. Enter @50,0 in the 
command line to move it 50 drawing units 
to the right, for example. 

○ The move dialog is displayed. 

• Choose 'Delete Original,' and copy 'Keep 
Original' in order to transfer the entities. 
Also, by selecting "Multiple Copies" and 
entering the number on the next text line, 
you may make a number of copies at once. 
Note that "9" creates nine duplicates, keeps 
the original, so that the chosen entities will 
eventually have ten instances. 

• The new entities are placed on the same 
layer as the originals and have the same 
properties. Instead, check "Utilize current 
layer and attributes" to use the layer and 
current attributes. 

EXPLAIN ONE DRWING METHOD IN SHORT 

• Angle Bisector 

Toolbar/Icon: 

      

Menu: Draw>Line>AngleBisector 

Shortcut: L,B 

Commands: linebisector | bisector | lb 

Description 

Use this tool for creating angle bisectors between 
two line entities. 
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Usage 

○ Choose the desired line type in the options 
toolbar. 

○ Enter the bisector(s) length from the junction 
of the two lines in the toolbar Options. Choose 
the angle bisectors that you wish to generate 
in the second text box. The default is '1' 
however additional bisectors may be created 
as illustrated below.: 

 

○ Click the first line entity which limits the angle. 

○ Place the mouse pointer on the side of the line 
on which you wish to make the angle bisector 
and click the second line entity (s). The angle 
bisector(s) are shown in the preview before 
they are generated. 

DISCUSS  ITEMS 

Main Application Window 

Some of the major application window components 
are also frequently accessible in other apps (e.g. the 
menubar or the toolbars). Additional components are 
CAD or perhaps QCad specific. The names by which 
the individual components of the QCad user interface 
are referred to in this handbook are shown in Figure 8. 

 

Menu and CAD Toolbar 

You can access most of QCad's features via its top 
menu. For tasks linked to CAD, the CAD toolbar on 
the left may be more handy. The functionality that is 
presently most useful is always shown in this toolbar. 
If the starting point of a line is to be set it displays for 
instance the grabbing capability to set the starting 
point to an existing endpoint, a grid or to apply a 
different positioning method. 

 

Layer List and Block List 

The layer list and block list may be found to the right of 
the main window of QCad. They display the current 
drawing layers and blocks and provide some basic 
tools, which are unique to the layer or block. The View 
- Views - Layer List and View - Views - Block List 
menu may enable you to turn on or off the list. 

Status Bar 

The status bar at the bottom of the programme 
window displays different information about QCad's 
current state. On the left, the coordinate widget shows 
a cartesian and polar coordinate with an absolute 
and relative location of the mouse pointer. The 
middle mouse widget provides information about 
the left and right mouse buttons' current operation. 
The right-hand selection widget displays the 
number of chosen entities. 

Using the option View - Views - Statusbar, you can 
enable or hide the status bar.. 

Command Widget 

You may locate the QCad command line just above 
the status bar (Professional version only). It is used 
for entering commands and for warning and error 
notifications. 

The command line can be enabled / disabled using 
the menu View - Views - Command-Line. 

Option Toolbar 

Figure 8 shows the toolbar option unfilled. It 
displays the choices accessible for the tool, 
depending on the current tool. You may wish to 
disable this toolbar using the View - Views - Option 
Toolbar menu if you prefer changing options and 
tool settings via the command line. 

Executing Commands 

Every operation in QCad is predicated on the 
execution of a command. QCad instructions can be 
run in three different ways.: 

1. Choose a tool icon from one of the toolbars 
that corresponds to the task at hand. 

2. From one of the pull-down menus, select a 
menu item. 

3. Use the command prompt to type a 
command. 

After being launched, most actions require 
additional user inputs. QCad can seek those inputs 
in three different ways: 

https://qcad.org/doc/qcad/latest/reference/en/scripts/Draw/Line/doc/Line_en.html#type
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∎ Dialogs. The text building tool, for example, 
displays a dialogue for selecting a font and 
entering the text entity's string. 

∎ Option toolbar is a toolbar that allows you to 
change the settings of your computer. The tool 
for drawing parallels, for example, requires the 
input of the parallel's distance from the original 
item. The user can type the distance into a 
text input box in the tool settings toolbar at the 
top. 

∎ Command-line interface. When drawing a 
series of lines, for example, you can end the 
sequence by putting 'close' into the command 
line. 

 

Modes 

In two modes, QCad operates: command mode and 
regular mode. It accepts instructions via the command 
line in command mode. All keyboard input flows to the 
programme interface in regular mode. 

Command Mode 

The command mode is shown on the left side of the 
command widget with a blue label and in the 
command line with a flashing cursor. Each keyboard 
input that may be printed enters the command line in 
this mode. To input instructions or co-ordinates, use 
this mode. For instance, a line may be entered to start 
the tool on the line. By pressing Z and the A key, the 
letters 'za' are shown in the command line instead of 
the command auto-zoom. When in normal mode, the 
command mode may be entered either by hitting the 
space key or clicking in the input box on the command 
line. 

Normal Mode 

QCad acts like any other standard programme in this 
mode. All keyboard entries are treated as hotkeys 
when they have been defined or have absolutely no 
impact. If you hit Z, then QCad will start auto zooming 
using the A key in this mode. Press the Escape key to 
go from Command Mode to Standard Mode. If there is 
any text in the input box on the command line, double-
click Escape. 

 

 

EXPLAIN TOOLBAR 

Toolbars and menus. You may wish to add your own 
script-based QCAD tools to a customised orr menu, so 
they may be started in a smooth and consistent 
manner. These instructions demonstrate how the 
ECMA Script structure comes with QCAD handling the 
menus and toolbars. 

∎ Command line. Spacebar. 
Activate command line. Esc. … 

∎ File Handlng. Ctrl+N. Create a New drawing. 
Ctrl+O. ... 

∎ Editing Shortcuts. OO/Ctrl+Z. Undo (oops) 
UU/Ctrl+Shift+Z. ... 

∎ View Shortcuts. RD. Redraw. ZW. ... 

∎ Layer Handling. FR* Freeze all layers. TH* 
... 

∎ Snapping. OS. Free positioning. SG. ... 

∎ Construction. PO. Point. LI. ... 

∎ Dimensioning. DA. Aligned Dimension. DH. 

CONCLUSION: 

The QCAD of this paper is to present the 
significance of mathematics thoughts in various 
fields of software applications. An outline is 
exhibited particularly to extend mathematics. 
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